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Chapter 1

Introduction

This user’s guide includes the following serial communication modules, all designed for use with 
Opto 22’s SNAP PAC System:

• SNAP-SCM-232

• SNAP-SCM-485-422

• SNAP-SCM-W2

• SNAP-SCM-PROFI

• SNAP-SCM-CAN2B

• SNAP-SCM-ST2

These modules conveniently provide serial data at a remote Ethernet location.

Port A
Port B

Port A
Port B

SNAP-SCM-232 SNAP-SCM-485-422
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Many industrial applications require digital, analog, and serial data to provide a complete solution. 
Traditionally, either separate serial network cabling is required for the serial devices, or an expensive 
data processor or PC must be used just to interface with the serial devices.

The SNAP serial communication modules eliminate this problem by providing high-speed, isolated 
serial communications packaged in the compact SNAP module form. The SNAP-SCM-232, 
SNAP-SCM-485-422, SNAP-SCM-W2, and SNAP-SCM-ST2 modules each provides two channels of 
serial data (one channel for a 4-wire SNAP-SCM-485-422). The SNAP-SCM-PROFI and 
SNAP-SCM-CAN2B modules each provides one channel.

Using the SNAP serial communication module as a converter, non-Ethernet devices can be 
connected to an Ethernet network and be available for control, monitoring, or data acquisition by 
any authorized PC or other device on the Ethernet network.

All SNAP serial communication modules snap into Opto 22 SNAP PAC mounting racks right beside 
SNAP I/O® digital and analog modules, to provide the mix of analog, digital, and serial channels you 
need at any location. 

SNAP-SCM-CAN2B Module SNAP-SCM-ST2 Module

SNAP-SCM-PROFISNAP-SCM-W2

Port A
Port B

Port B
Port A
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Typical Applications
Typical applications for the SNAP-SCM-232 and the SNAP-SCM-485-422 include interfacing with 
printers, scales, chart recorders, and barcode systems. 

• The SNAP-SCM-232 interfaces to auxiliary serial equipment via two RJ-45 plug-in data 
connectors, providing two RS-232 serial ports. This model also supports optional RTS/CTS flow 
control. 

• The SNAP-SCM-485-422 uses a simple screw-type connector for easy wiring of two 2-wire 
RS-485 ports or one 4-wire RS-485/422 port. 

• The SNAP-SCM-W2 is ideal for security applications. It complies with the Security Industry 
Association Access Control Standard Protocol for the 26-bit Wiegand® Reader Interface. The 
module receives incoming data from card readers, keypads, or other Wiegand devices. 

• The SNAP-SCM-PROFI integrates a PROFIBUS DP® network into your system. It uses a built-in 
DB-9 connector to provide a standard electrical interface between Ethernet-based Opto 22 
SNAP I/O systems and PROFIBUS DP networks. For information on how to integrate an Opto 22 
controller with a PROFIBUS DP network, see form 1591, the PROFIBUS DP Master Technical Note.

• The SNAP-SCM-CAN2B provides an interface to a Controller Area Network (CAN) that allows 
your SNAP PAC system to receive data from CAN devices. Once the module is installed, 
integration with your system is done using the CAN Integration Kit, part number PAC-INT-CAN, 
which is a free download from the Product section of our website, www.opto22.com.

• The SNAP-SCM-ST2 provides pulse and direction signals for up to two stepper motors which 
can be controlled by a SNAP PAC controller running a PAC Control™ strategy.

What’s in this Guide?
This guide assumes that you have some familiarity with Ethernet networking and serial 
communication. If you are using a SNAP Wiegand module, you should be familiar with the Wiegand 
interface. If you are using a SNAP PROFIBUS DP module, you should understand the PROFIBUS DP 
protocol. Commercial resources are available for learning about these subjects. To learn more about 
the SNAP PAC System, visit the Opto 22 website at www.opto22.com.

This guide includes the following sections:

• Quick Start to get your serial module up and running quickly

• Instructions for changing communication parameters, configuring Wiegand and CAN2B 
modules, using ST2 commands, loading new firmware, building cables, and more

• Specifications, LEDs, and Module Switches

NOTE: This guide does not cover SNAP-SCM-MCH16 or SNAP-SCM-SSI modules. For the 
SNAP-SCM-MCH16, see form 1673, the SNAP PAC Motion Control User's Guide. For the SNAP-SCM-SSI, see 
form 1931, the SNAP SSI (Serial Synchronization Interface) Module User’s Guide.

http://www.opto22.com/documents/1591_PROFI_master_tech_note.pdf
http://www.opto22.com/
http://www.opto22.com/
http://www.opto22.com/documents/1673_Motion_Control_Users_Guide.pdf
http://www.opto22.com/documents/1931_SNAP_SSI_Module_Users_Guide.pdf
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For Help
If you have problems installing or using SNAP serial communication modules and cannot find help 
in this guide or on our website, you can contact Opto 22 Product Support. 

Phone: 800-TEK-OPTO (800-835-6786)
951-695-3080
(Hours are Monday through Friday, 
7 a.m. to 5 p.m. Pacific Time)

Fax: 951-695-3017

Email: support@opto22.com

Opto 22 website: www.opto22.com

When calling for technical support, be prepared to provide the following information about your 
system to the Product Support engineer:

• Software and version being used

• Controller firmware version (if applicable)

• PC configuration

• A complete description of your hardware, including:

– IP addresses and net masks for devices on the system

– type of power supply (brand and model)

– types of I/O units installed

– third-party devices installed (for example, barcode readers)

– jumper configuration, if applicable

– accessories installed (such as expansion cards)

• Specific error messages seen.

NOTE: Email messages and phone 
calls to Opto 22 Product Support 
are grouped together and 
answered in the order received.
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Chapter 2

Quick Start

In this chapter:
Check Processor Compatibility............................................... page 5
Install the Module ........................................................................ page 6
Attach Serial Devices................................................................... page 7
Apply Power to the Rack ........................................................... page 11
Configure the Module ................................................................ page 11
Establish an Ethernet Connection......................................... page 13
Send and Receive Data through the Module .................. page 14

Check Processor Compatibility
SNAP serial communication modules can be used with any of the following SNAP PAC 
rack-mounted controllers and brains:

These modules cannot be used with SNAP PAC serial-based brains (SNAP-PAC-SB1 and 
SNAP-PAC-SB2). If you are using an older brain or rack-mounted controller, such as SNAP Ultimate or 
SNAP Ethernet, see Appendix B, “Using SNAP Serial Modules with Legacy Hardware,” to determine 
compatibility.

SNAP-PAC-R1
SNAP-PAC-R1-FM
SNAP-PAC-R1-W
SNAP-PAC-R2
SNAP-PAC-R2-FM
SNAP-PAC-R2-W

SNAP-PAC-EB1
SNAP-PAC-EB1-FM
SNAP-PAC-EB1-W
SNAP-PAC-EB2
SNAP-PAC-EB2-FM
SNAP-PAC-EB2-W
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Install the Module
SNAP serial communication modules can be installed in any position on an Opto 22 SNAP PAC 
mounting rack. Do not install more than eight serial communication modules of any type on the 
same rack.

NOTE: SNAP serial communication modules draw considerably more power than a standard SNAP analog 
or digital module. The rack can handle a maximum of eight serial modules, plus the processor and up to 
eight digital or analog modules. See serial module specifications on page 47. Make sure you have sufficient 
power for the processor and all modules on the rack.

1. Turn off power to the rack. 

WARNING: Make sure power is off before continuing, or you will severely damage the module.

2. Remove the module from its packaging. 
3. Position the module over the 

connector on the rack, aligning the 
small slot at the base of the module 
with the retention bar on the rack. 
If it is next to another module, make 
sure the male and female module 
keys are aligned, as shown at right.

4. Push straight down on the module 
to snap it into position.

If you need to remove the module, 
see page 34.
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Bias and Termination (SNAP-SCM-485-422 and 
SNAP-SCM-PROFI Only)
If you are using the SNAP-SCM-485-422 or 
SNAP-SCM-PROFI, use the small switches 
on the top of the module to provide bias 
or termination on the RS-485/422 or 
PROFIBUS DP network as required. Bias 
and termination switches are shown in 
the diagrams at right.

Termination

If the port is physically the first or last 
device on the network, provide 
termination as follows:

SNAP-SCM-485-422—Move the Term 
switch to ON.

SNAP-SCM-PROFI—If you are using an 
official PROFIBUS cable, termination is 
provided in the cable; therefore, switch 
the termination to ON in the cable and 
move the Term switch to OFF in the 
SNAP-SCM-PROFI module.

Bias

Provide bias at one point on the network 
by moving both the Pull Up and Pull 
Down switches to ON.

Attach Serial Devices

SNAP-SCM-232
If you have a SNAP-SCM-232, use the supplied cable and adapters to connect a serial device to each 
port on the module. 

Pinouts for the RJ-45 connectors and DB-9 (male) adapters on the SNAP-SCM-232 are shown below.

Power
 

SNAP-SCM-485-422

SNAP-SCM-PROFI

Not Used

Pull Down Resistor
Termination

Pull Up Resistor

Receive
Run

Transmit

Communication 
Switches

Serial Port

OFF ON
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NOTE: RTS/CTS is optional; to use this mode, see “Configuring Flow Control and 2- or 4-Wire Mode” on 
page 18. 

SNAP-SCM-485-422
If you have a SNAP-SCM-485-422, use the supplied terminal strip to connect serial devices to each 
port, as shown in the diagrams and tables below. Two-wire mode is the default; to use four-wire 
mode, see “Configuring Flow Control and 2- or 4-Wire Mode” on page 18. 

NOTE: Vcc on the SNAP-SCM-485-422 is 5 VDC and is supplied by the module itself. Do not use this voltage 
to power another device, as it can interfere with normal module operation.

RJ-45 Connectors

1 Not used

2 RX (receive data)

3 TX (transmit data)

4 RTS (request to send) 

5 GND (signal ground)

6 Not used

7 Not used

8 CTS (clear to send)

DB-9 (male) Adapters

1 Not used

2 RX (receive data)

3 TX (transmit data)

4 Not used

5 COM (signal ground)

6 Not used

7 RTS (request to send) 

8 CTS (clear to send)

9 Not used

Pinouts for Two-Wire 
SNAP-SCM-485-422

Pin Port Description

1 A Vcc

2 A TX/RX +

3 A TX/RX -

4 A Sig Gnd

5 B Vcc

6 B TX/RX +

7 B TX/RX -

8 B Sig Gnd

SNAP-SCM-485-422 Top View

1 or 5
2 or 6
3 or 7
4 or 8

SNAP-SCM-485-422RS-485 DeviceTwo-Wire Mode

TX/RX +
TX/RX –
Sig Gnd
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SNAP-SCM-W2
If you have a SNAP-SCM-W2, use the supplied terminal strip to connect a Wiegand serial device to 
each port on the module, as shown in the diagram and table below.

IMPORTANT: Some devices such as card readers can use other protocols. Make certain that your device has 
been correctly configured to use the Wiegand protocol. 

SNAP-SCM-PROFI
Pinouts for the DB-9 connector on the SNAP-SCM-PROFI are shown in the diagram and table below. 
For information on how to set the communication switches, see “Module 
Switches—SNAP-SCM-PROFI” on page 55.

Pinouts for Four-Wire 
SNAP-SCM-485

Pin Port Description

1 A Vcc

2 A TX +

3 A TX –

4 A Sig Gnd

5 A Vcc

6 A RX +

7 A RX –

8 A Sig Gnd

1
2 TX +
3 TX –
4 Sig Gnd
5
6 RX +
7 RX –
8

SNAP-SCM-485-422Serial Device

RX +
RX –
Sig Gnd
TX +
TX –

Four-Wire Mode

Pinouts for SNAP-SCM-W2

Pin Port Color Description

1 A Black Common

2 A White Data One

3 A Green Data Zero

4 A -- Do not use

5 B Black Common

6 B White Data One

7 B Green Data Zero

8 B -- Do not use

SNAP-SCM-W2 Top View
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SNAP-SCM-CAN2B
Pins 1-4 are in parallel to pins 5-8. V+ is not used by the SNAP-SCM-CAN2B module.

SNAP-SCM-ST2
Connect a stepper motor to each port on the module, as shown in the diagram and table below.

Pinouts for 
SNAP-SCM-PROFI

Pin Description

1 Not used

2 Not used

3 RxD/TxD+

4 Enable

5 Dgnd

6 VP

7 Not used

8 RxD/TxD–

9 Not used

1

68

345

SNAP-SCM-PROFI Top View

DB-9 
Connector

SNAP-SCM-CAN2B Top View

Pinouts for SNAP-SCM-CAN2B

Pin Use

1,5 V +

2,6 CAN +

3,7 CAN –

4,8 GND

LEDs

Pin 1



QUICK START

SNAP Serial Communication Module User’s Guide 1111

Apply Power to the Rack
Power can usually be supplied by an Opto 22 SNAP-PS5 power supply; however, check total power 
requirements for all modules and the processor. 

When you apply power to the rack, the SNAP-SCM-232 and the SNAP-SCM-485-422 respond by 
blinking their TX LEDs (see diagram above for LED location). Additionally, on the SNAP-SCM-232 and 
SNAP-SCM-485-422, unless you have changed the default, a test message similar to the following is 
sent to the attached serial devices: 

Opto 22 SNAP-SCM232, Ver 00.01.01.01, Module 7, Port 0, 9600,N,8,1

Configure the Module

SNAP-SCM-232 and SNAP-SCM-485-422 Configuration
Default communication parameters for the SNAP-SCM-232 and SNAP-SCM-485-422 are as follows:

• 1 start bit

• 9600 baud

• No parity

• 8 data bits

• 1 stop bit

• SNAP-SCM-232: No flow control

• SNAP-SCM-485-422: Two-wire mode

SNAP-SCM-ST2 Top View

LEDs

Pin 1

Pin Port Use Description

1

A

Pulse Frequency output

2 Ground Isolated from logic side

3 Direction +5 VDC when asserted 
0 VDC when deasserted

4 Ground Isolated from logic side

5

B

Pulse Frequency output

6 Ground Isolated from logic side

7 Direction +5 VDC when asserted
0 VDC when deasserted

8 Ground Isolated from logic side

Port A

Port B
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If you plan to use the default parameters, configuration is already finished. If you need to change the 
communication parameters, see page 15.

SNAP-SCM-PROFI Configuration
Default communication parameters for the SNAP-SCM-PROFI module are as follows:

• 1 start bit

• 9600 baud

• Even parity

• 8 data bits

• 1 stop bit

• Send a test message when the module is turned on.

If you plan to use the default parameters, configuration is already finished. If you need to change the 
communication parameters, see page 20. Note that on the SNAP-SCM-PROFI module you can 
configure only the Baud Rate, Power-up Test Message, and EOM Character List.

SNAP-SCM-W2 Configuration
Use PAC Manager to configure SNAP-SCM-W2 serial modules, which involves telling the module 
what bit pattern you are using to transmit site and badge code data. For detailed configuration 
instructions see page 23.

SNAP-SCM-CAN2B Configuration
The SNAP-SCM-CAN2B module has the following default settings. Use PAC Manager to change the 
settings as described on page 26.

• IP Port Number: This number is different for each slot.

• Baud Rate: 250000

• Data Masks and Filters: These are all set to 0.

If you plan to use the default parameters, configuration is already finished. Otherwise, see 
“Configuring CAN Modules” on page 26.

SNAP-SCM-ST2 Configuration
Once you have established an Ethernet connection (see below) you are ready to use the ST2’s 
output commands. For more information, see “Using the SNAP-SCM-ST2 Module Commands” on 
page 29. No other configuration is necessary.
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Establish an Ethernet Connection
An Ethernet connection in the software application is required in order to establish communication 
with the serial device that is attached to the SNAP serial communication module. In Opto 22’s PAC 
Control, for example, you would do the following things:

• Create a communication handle. See “Communication Handles for Serial Communication 
Modules” in chapter 10 of the PAC Control User's Guide, form 1700.

• Use the comm handle in the Open Outgoing Communication command, and follow that with 
the Communication Open? command. See form 1701, the PAC Control Command Reference. In 
the legacy software OptoControl™, you would use the command Open Ethernet Session.

To establish an Ethernet connection, you need the IP address of the I/O unit. You also need the IP 
Port number of the module’s serial port from the following table. Note that SNAP-SCM-PROFI and 
SNAP-SCM-CAN2B modules have only one port, port A.

(This table shows the default port numbers. You can change them if necessary using PAC Manager. 
See “Changing SNAP-SCM-232 and SNAP-SCM-485-422 Communication Parameters” on page 15 or 
“Configuring Wiegand Modules” on page 23.) 

NOTE: If a connection is not established, the serial module buffers incoming characters and saves them 
until a connection is established. For REVISION A modules (those manufactured in June 2003 or after), the 
buffer holds 999 characters. For modules prior to REVISION A, the buffer holds 247 characters.

Module 
Position

Port IP Port Number Module 
Position

Port IP Port Number

0
A 22500

8
A 22516

B 22501 B 22517

1
A 22502

9
A 22518

B 22503 B 22519

2
A 22504

10
A 22520

B 22505 B 22521

3
A 22506

11
A 22522

B 22507 B 22523

4
A 22508

12
A 22524

B 22509 B 22525

5
A 22510

13
A 22526

B 22511 B 22527

6
A 22512

14
A 22528

B 22513 B 22529

7
A 22514

15
A 22530

B 22515 B 22531

http://www.opto22.com/documents/1700_PAC_Control_Users_Guide.pdf#G12.1546184
http://www.opto22.com/documents/1700_PAC_Control_Users_Guide.pdf#G12.1546184
http://www.opto22.com/documents/1701_PAC_Control_Command_Reference.pdf
http://www.opto22.com/documents/1700_PAC_Control_Users_Guide.pdf
http://www.opto22.com/documents/1701_PAC_Control_Command_Reference.pdf#M6.8.newlink.IDHOpenOutgoingCommunication
http://www.opto22.com/documents/1701_PAC_Control_Command_Reference.pdf#M6.8.newlink.IDHCommunicationOpen
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Send and Receive Data through the Module
Once the Ethernet connection is established, you use a normal Ethernet send or recv to send or 
receive characters over the serial port. In PAC Control, for example, you would use commands such 
as Transmit String, Transmit Numeric Table, and Receive String Table. 
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Chapter 3

Module Configuration

In this chapter:
Changing SNAP-SCM-232 and SNAP-SCM-485-422 Communication Parameters................page 15
Changing SNAP-SCM-PROFI Communication Parameters ...............................................................page 20
Configuring Wiegand Modules.....................................................................................................................page 23
Configuring CAN Modules ..............................................................................................................................page 26
Using the SNAP-SCM-ST2 Module Commands .....................................................................................page 29
Configuring Serial Events and Reactions ..................................................................................................page 32

Changing SNAP-SCM-232 and SNAP-SCM-485-422 
Communication Parameters

Communication parameters on the SNAP-SCM-232 and SNAP-SCM-485-422 serial modules can be 
changed using PAC Manager utility software. PAC Manager comes on a CD with all SNAP PAC brains 
and controllers and is also available for free download from our website, www.opto22.com.

Default configuration parameters for the SNAP-SCM-232 and SNAP-SCM-485-422 are:

• 1 start bit (not configurable)

• 9600 baud

• No parity

• 8 data bits

• 1 stop bit

• Send a test message when the module is turned on.

• SNAP-SCM-232: No flow control

• SNAP-SCM-485-422: 2-wire mode

Changing Basic Parameters
You will need to have a PC with PAC Manager installed on the same Ethernet network as the I/O 
unit.
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All parameters listed above except the last two (flow control and 2- or 4-wire mode) can be changed 
in the I/O unit’s configuration file using the following steps. For flow control and 2- or 4-wire mode, 
see the steps on page 18. 
1. On the PC, choose Start > Programs > Opto 22 > PAC Project > PAC Manager.
2. In the PAC Manager main window, click the Open button or choose File > Open. Navigate to 

the location of the configuration file and double-click the filename.
3. In the configuration tree, right-click the name of the I/O unit the serial module is on. 

From the pop-up menu, choose Configure.

The Configure I/O Units dialog box opens.

4. Make sure the correct I/O unit is highlighted. Click the Modules button and choose Serial 
Modules from the pop-up menu. 

5. Click the status cell for the module number and port number whose parameters you want to 
change. From the pop-up menu, choose Enabled.

The Status changes to Enabled.

Modules 
button
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6. To change a communication parameter, click the cell you want to change within the 
highlighted line. Choose from the drop-down list, if there is one, or type the new value in the 
cell. 

EOM Chars: The device can check any one of up to four characters as the end-of-message 
indicator. EOM checking occurs only when using the serial module port with serial events. 
Enter up to four characters in hex. Example: 0x0D0A0000 looks for a 13 (hex 0D) or a 10 (hex 
0A). 

NOTE: The start bit is not configurable. To set flow control and 2- or 4-wire mode, see the steps on 
page 18.

7. When you have finished changing parameters for serial modules, click OK. Then click Close.
8. With the configuration file open, choose Tools > Send Configuration to I/O Unit.

The Send Configuration dialog box appears: 

The list on the left shows all the I/O units in this configuration file. When you click a unit, 
the Address List shows the IP addresses for all I/O units to receive the same configuration. 

9. Highlight the I/O unit configuration(s) you want to send.
10. Highlight the IP addresses to receive the I/O unit configuration.

If you don’t highlight any addresses, the configuration will be sent to the entire list.

NOTE: If you highlighted more than one unit configuration, each unit configuration will 
automatically be sent to all the IP addresses associated with it. 

11. If necessary, change the Timeout field.

The timeout field shows how long, in milliseconds, PAC Manager will try to communicate with 
the I/O unit before returning a timeout error.

12. To save the configuration file to flash memory as well as to RAM, check Save to Flash. To also 
restart the unit, check Restart I/O Unit. 

IMPORTANT: If you have changed an IP Port number, you must save the change to flash and restart 
the I/O unit.

13. Click Send.

The configuration data is sent to the I/O units whose IP addresses you chose.
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Configuring Flow Control and 2- or 4-Wire Mode
You can configure flow control on a SNAP-SCM-232 and 2- or 4-wire mode on a SNAP-SCM-485-422 
using PAC Manager. However, these configurations cannot be saved to a configuration file. The I/O 
unit that contains the serial module must be on the same network as your PC, and the configuration 
is sent directly to the I/O unit. 
1. On a PC on the same Ethernet network as the I/O unit, choose Start > Programs >Opto 22 > 

PAC Project > PAC Manager.

2. In the PAC Manager main window, click the Inspect icon  or choose Tools > Inspect.

3. In the Device Name field, type the name or IP address of the I/O unit, or choose it from the 
drop-down list. Click the Communications button and choose Serial Modules from the menu.
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Information from the I/O unit is displayed in the window:

4. Click the Serial Module Number drop-down list and choose the module’s position number on 
the rack to see the module’s communication parameters.

5. To change a parameter, click its value in the Value column and choose from the drop-down list 
or enter a new value.

NOTE: This is the only way to change hardware flow control for a SNAP-SCM-232 or 2- or 4-wire mode 
for a SNAP-SCM-485-422. You can also change other parameters in this dialog box if necessary. 
However, parameters changed in this dialog box are NOT saved to the configuration file.

This example shows how to change Hardware Flow Control on a SNAP-SCM-232:
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6. When you have finished changing parameters for this module, click Apply. 

The configuration changes are sent to the I/O unit. 

Changing SNAP-SCM-PROFI Communication Parameters
Communication parameters on the SNAP-SCM-PROFI serial module can be changed using PAC 
Manager. 

Default communication parameters for the SNAP-SCM-PROFI are:

• 1 start bit (not configurable)

• 9600 baud

• Even parity (not configurable)

• 8 data bits (not configurable)

• 1 stop bit (not configurable)

• Send a test message when the module is turned on.

To change parameters, you will need a PC on the same Ethernet network as the I/O unit.
1. On the PC, choose Start > Programs > Opto 22 > PAC Project > PAC Manager.
2. In the PAC Manager main window, click the Open button or choose File > Open. Navigate to 

the location of the configuration file and double-click the filename.
3. In the configuration tree, right-click the name of the I/O unit the SNAP-SCM-PROFI module is 

on. From the pop-up menu, choose Configure.
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The Configure I/O Units dialog box opens:

4. Make sure the correct I/O unit is highlighted. Click the Modules button and choose 
Profibus Modules from the pop-up menu. 

5. In the Number field, choose the Profibus module’s position from the drop-down list. 
Click to put a check mark in the Used box.

6. To change a communication parameter, click the cell you want to change within the 
highlighted line. Choose from the drop-down list, if there is one, or type the new value in the 
cell. 

EOM Chars: The device can check any one of up to four characters as the end-of-message 
indicator. EOM checking occurs only when using the serial module port with serial events. 
Enter up to four characters in hex. Example: 0x0D0A0000 looks for a 13 (hex 0D) or a 10 (hex 
0A). 

NOTE: You can configure only IP Port Number, Baud Rate, Power-up Test Message?, and EOM 
Character List. The other parameters are not configurable.

Modules 
button
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7. When you have finished changing parameters for the SNAP-SCM-PROFI module, click OK. 
Configure another module or click Close.

8. With the configuration file open, choose Tools > Send Configuration to I/O Unit.

The Send Configuration dialog box appears: 

The list on the left shows all the I/O units in this configuration file. When you click a unit, 
the Address List shows the IP addresses for all I/O units to receive the configuration. 

9. Highlight the I/O unit configuration(s) you want to send.
10. Highlight the IP addresses to receive the I/O unit configuration.

If you don’t highlight any addresses, the configuration will be sent to the entire list.

NOTE: If you highlighted more than one unit configuration, each unit configuration will 
automatically be sent to all the IP addresses associated with it. 

11. If necessary, change the Timeout field.

The timeout field shows how long, in milliseconds, PAC Manager will try to communicate with 
the I/O unit before returning a timeout error.

12. To save the configuration file to flash memory as well as to RAM, check Save to Flash. 
To also restart the unit, check Restart I/O Unit. 

IMPORTANT: If you have changed an IP Port number, you must save the change to flash and restart 
the I/O unit. 

13. Click Send.

The configuration data is sent to the I/O units whose IP addresses you chose.
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Configuring Wiegand Modules 
This section includes step-by-step instructions for telling a SNAP-SCM-W2 what bit pattern you 
are using to transmit site and badge code data.

Sample Strategy 
If you are using the SNAP Wiegand module for card reader access to 16 or fewer doors by 4200 or 
fewer users, you can download and use the sample control strategy and utility software available on 
our website at www.opto22.com. (The sample strategy is an ioControl strategy but can be opened 
in PAC Control.) The strategy configures the modules, processes card reader data, and sends SNMP 
traps for security monitoring. The utility manages user names and entry permissions. 

The sample strategy assumes a 37-bit code with the following format:
Bits-1234 5678 9012 3456 7890 1234 5678 9012 3456 7
Code-P000 0000 SSSS SSSS SBBB BBBB BBBB BBBB BBBB P

Key: P = parity bit
0 = zero-filled
S = Site code
B = Badge code

Both samples include source code and can be used as is or modified to fit your application. See 
Opto 22 form 1366, the Door Access Manager Technical Note, for more information. 

If your situation does not match the sample strategy, you can follow the steps below to 
configure SNAP-SCM-W2 modules. For additional information on configuration, see Opto 22 Form 
1704, the PAC Manager User’s Guide, available from our website at www.opto22.com:

Configuring Your Own Modules
IMPORTANT: Some serial devices such as card readers can use other protocols. Make sure your device has 
been correctly configured to use the Wiegand protocol.

The SNAP-SCM-W2 conforms to the data transmission standards of the Wiegand 26-bit reader 
interface protocol. However, note the following:

• The first and last few bits of the transmission can optionally be parity bits, but due to the 
number of possible variations, no parity or CRC checking is done by the SNAP Wiegand 
module.

• The SNAP Wiegand module can accommodate transmissions from 26 bits to 64 bits. The site 
code always comes before the badge code and can be a maximum of 32 bits. The badge code 
immediately follows the site code (regardless of the length of the site code) and can also be a 
maximum of 32 bits. Parity bits at the beginning and end of the transmission, if used, reduce 
the total number of possible site and badge code bits.

To configure Wiegand modules, use PAC Manager on a PC on the same network as the I/O unit.
1. On the PC, choose Start > Programs > Opto 22 > PAC Project > PAC Manager.
2. In the PAC Manager main window, click the Open button or choose File > Open. Navigate to 

the location of the configuration file and double-click the filename.
3. In the configuration tree, right-click the name of the I/O unit the Wiegand module is on. 

From the pop-up menu, choose Configure.

http://www.opto22.com/documents/1366_Access_Door_Mgr_Tech_Note.pdf
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The Configure I/O Units dialog box opens:

4. Make sure the correct I/O unit is highlighted. Click the Modules button and choose Wiegand 
Modules from the pop-up menu. 

Modules 
button
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5. In the Number field, choose the Wiegand module’s position from the drop-down list. 
Click to put a check mark in the Used box. 

6. If you need to change port numbers, enter the new numbers for each port in the IP Port 
Number fields.

7. Click the Format/Value cell, and from the drop-down list, choose a standard data format 
(shown by its total data length) or choose C for custom. 

NOTE: O is the 37-bit Opto 22 format used in the sample control strategy. 

8. Change the following fields if necessary to match your Wiegand hardware device:

Data Length—total length of data in the transmission
Site Position—first bit of the site code
Site Length—length of the site code, in bits
Badge Position—first bit of the badge code (should be the next bit after the site code)
Badge Length—length of the badge code, in bits

9. When data for both ports is correct, repeat from step 5 for additional Wiegand modules. 
10. When all Wiegand modules are configured, click OK. Close the Configure I/O units dialog box.
11. In the main PAC Manager window, choose Tools > Send Configuration to I/O Unit. 

The Send Configuration dialog box appears: 

The list on the left shows all the I/O units in this configuration file. When you click a unit, 
the Address List shows the IP addresses for all I/O units to receive the configuration. 

12. Highlight the I/O unit configuration(s) you want to send.
13. Highlight the IP addresses to receive the I/O unit configuration.

If you don’t highlight any addresses, the configuration will be sent to the entire list.

NOTE: If you highlighted more than one unit configuration, each unit configuration will 
automatically be sent to all the IP addresses associated with it. 

14. If necessary, change the Timeout field.

The timeout field shows how long, in milliseconds, PAC Manager will try to communicate with 
the I/O unit before returning a timeout error.

15. To save the configuration file to flash memory as well as to RAM, check Save to Flash. To also 
restart the unit, check Restart I/O Unit. 
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IMPORTANT: If you have changed an IP Port number, you must save the change to flash and restart 
the I/O unit. 

16. Click Send.

The configuration data is sent to the I/O units whose IP addresses you chose.

Configuring CAN Modules
Configuration for the SNAP-SCM-CAN2B module is normally done in a PAC Control strategy using 
the example charts from the CAN Integration Kit for PAC Project, part number PAC-INT-CAN, a free 
download available on our website, www.opto22.com. As described below, you can also use PAC 
Manager to change the IP Port Number, Baud Rate, Data Masks, or Filters for the SNAP-SCM-CAN2B 
serial module. However, the settings in your strategy will override the settings in PAC Manager for 
each module.
1. Using a PC on the same Ethernet network as the I/O unit, choose Start > Programs > Opto 22 > 

PAC Project > PAC Manager.

2. In the PAC Manager main window, click the Inspect icon  or choose Tools > Inspect.

3. In the Device Name field, type in the name or IP address of the I/O unit, or choose it from the 
drop-down list. 

4. Click the Communications button and choose CAN Modules from the pop-up menu.

Information from the I/O unit is displayed in the window.

http://www.opto22.com/
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5. Click the CAN Module number drop-down list and choose the module’s position number on 
the rack to see the module’s communication parameters.

6. To change a parameter, click its value in the Value column. 

To change the Baud Rate on a SNAP-SCM-CAN2, choose from the drop-down list

To change the Filter or Data Mask values, see the next section below.

7. When you have finished changing parameters for this module, click Apply. 

The configuration changes are sent to the I/O unit. In the next steps you will store the 
configuration to flash memory.

8. Click Status Write.

CAN module 
number
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9. In the Operation Command list at the bottom of the window, highlight Store configuration to 
flash.

Note that this command saves to flash the things you can configure in PAC Manager. It does 
not affect a PAC Control strategy, which is saved to flash via PAC Control or PAC Terminal.

CAUTION: If you are using PAC Manager 9.0 or newer, firmware 9.0 or newer, and loader version 6.0 or 
newer, and if a controller has a microSD card installed and the card already contains configuration 
data, that data will be overwritten. See the controller user’s guide for complete information about 
microSD.

10. Click Send Command. 

The configuration data is stored to flash memory and a Success message appears.

SNAP-SCM-CAN2B Filters and Data Masks
The filters and data masks for each CAN2B module are normally configured in a PAC Control strategy 
using the example charts provided in the CAN Integration Kit for PAC Project, part number 
PAC-INT-CAN. You can also use PAC Manager to configure these settings. However, the filter and 
data mask settings in your PAC Control strategy will override the settings in PAC Manager for each 
module.

In PAC Manager the Data Masks and Filters are all set to 0 by default, which means that all CAN 
packets will be received. If you want the SNAP-SCM-CAN2B module to provide filtering, then you'll 
have to configure the Data Masks and Filters. Always start with the highest priority mask and filter, 
Data Mask 0 and Filter 0.

The memory map addresses for module slot 0 are 0xF03A9008, 0xF03A900C, 0xF03A9010, 
0xF03A9014, 0xF03A9018, 0xF03A901C, 0xF03A9020, and 0xF03A9024.
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Use the following table to determine how CAN packets are accepted or rejected. For example, if you 
want to receive CAN ID 0x00FF0500 and only care about the part in bold, then set your Mask to 
0x00FFFF00 and your Filter to 0x00FF0500.

In the following examples, the bits we care about are determined by the Data Mask.

Packet Accepted Example. 
This packet is accepted because the Filter bits match the CAN Packet bits.
Data Mask  = 0000 0000 1111 1111 1111 1111 0000 0000

Filter  = XXXX XXXX 1111 1111 0000 0101 XXXX XXXX

CAN Packet = XXXX XXXX 1111 1111 0000 0101 XXXX XXXX

Packet Rejected Example. 
This packet is rejected because the Filter bits do not match the CAN Packet bits.
Data Mask  = 0000 0000 1111 1111 1111 1111 0000 0000

Filter  = XXXX XXXX 1111 1111 0000 0101 XXXX XXXX

CAN Packet = XXXX XXXX 1111 1111 0001 0111 XXXX XXXX

Using the SNAP-SCM-ST2 Module Commands
In order to use the commands for this module, first you need to establish an Ethernet connection in 
the software application that communicates with the serial device attached to the ST2 module. For 
instructions, first see “Establish an Ethernet Connection” on page 13.

The SNAP-SCM-ST2 module supports the following pulse output commands in PAC Control:

• SetPulseFrequency outputs a set frequency until instructed to do otherwise.

• SetPulseSequence ramps from one frequency to another.

• ReadPulseFrequency returns a string representing a channel’s current frequency.

These commands are not part of the PAC Control command set. Rather, they are entered in a 
PAC Control strategy as parameters in a Transmit/Receive String command (or OptoScript 
TransmitReceiveString command).

Data Mask Bit Filter Bit CAN ID Bit Accept/Reject

0 X* X* Accept

1 0 0 Accept

1 0 1 Reject

1 1 0 Reject

1 1 1 Accept

* X = Don't Care
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The Transmit/Receive String command sends the pulse output command to the processor and then 
waits for a response. For more information on the Transmit/Receive String command, see the PAC 
Control Command Reference, form 1701.

Command examples shown below are in OptoScript, but you can accomplish the same thing with 
the standard command. Syntax for the OptoScript TransmitReceiveString command is:
TransmitReceiveString(String, Communication Handle, Put Result in)

ReadPulseFrequency
NOTE: This command requires SNAP-SCM-ST2 module firmware version R1.0d or newer, which is available 
as a download file on the Opto 22 website. For installation instructions, see form 1704, the PAC Manager 
User’s Guide.

If successful, this command returns a string representing a channel’s current frequency. If the 
command fails, it returns 00 (0x3030).

The command has no parameters.

The returned frequency always shows four decimal places, and the sign reflects the channel’s 
current direction. The string is terminated with an end-of-message character.

Examples of returned strings:

• 5000.0000

• 12.3456

• 0.0000

• –1.4290

Example

This example places the current frequency for comSCMStPort1 into the chan1Frequency string 
variable:

SetPulseFrequency
Outputs a set frequency until instructed otherwise.

The Frequency parameter indicates in hertz (Hz) the desired output frequency.

If Frequency is positive, then the module will assert the Direction pin. If Frequency is negative, then 
it will deassert the Direction pin. See “SNAP-SCM-ST2” on page 10 for descriptions of the Direction 
output pins.

Example 1

This OptoScript example outputs 50 kHz, 50% duty cycle, direction pin asserted. The result is placed 
in sReturn1.

NOTE: The > in the string is required to parse the serial data sent to the module.

nStatus = TransmitReceiveString(">ReadPulseFrequency()", comScmStPort1, chan1Frequency);

nStatus = TransmitReceiveString(">SetPulseFrequency(50000)", comScmStPort1, sReturn);

http://www.opto22.com/documents/1701_PAC_Control_Command_Reference.pdf#M6.8.newlink.IDHTransmitReceiveString
http://www.opto22.com/documents/1701_PAC_Control_Command_Reference.pdf
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Example 2

This example stops pulsing on the channel. The result is placed in sReturn1.

Example 3

This example outputs 30 kHz, 50% duty cycle, direction pin deasserted. The result is placed in 
sReturn1.

SetPulseSequence
Ramps from one frequency to another. Once the Stop Frequency is reached, it continues to output 
the Stop Frequency until told otherwise.

nStatus = TransmitReceiveString(">SetPulseFrequency(0)", comScmStPort1, sReturn);

nStatus = TransmitReceiveString(">SetPulseFrequency(-30000)", comScmStPort1, sReturn);

Parameter Units Description

Start Frequencya,b Hz The initial frequency. Must be nonzero. 

Stop Frequencya,b Hz The frequency you want to ramp to. May be zero.

Delta Frequencya,c Hz Frequency increments/decrements based on the Time Slice. Must be non-zero.

Time Sliced ms How often the Delta Frequency is applied to the current frequency. The maximum 
value is 42,949,672.

a. If the Start Frequency and Stop Frequency are positive, the module will assert the Direction pin during the 
pulse sequence. If the Start and Stop Frequency are negative, it will deassert the Direction pin.
b. Start Frequency and Stop Frequency cannot have opposite signs (for example, you cannot ramp from –3000 
to 1000 Hz).
c. If Time Slice is less than one half the period of the current frequency, then the Delta Frequency is boosted 
proportionately.
Example: Current frequency = 100 Hz, Time Slice = 1 ms, and Delta Frequency = 10 Hz.
You would expect the frequency to increase/decrease 10 Hz every 1 ms. But since the frequency can only 
change as fast as one half the period (see note c) it won't update for at least 5 ms. At this time it will temporarily 
boost the Delta Frequency 5x, or increase the current frequency from 100 Hz to 150 Hz to make up for the 
missed Time Slices.
d. Frequency can only change as fast as one half the period. In other words, at least one pulse must be exe-
cuted before changing the frequency.
Example: If the current frequency is 100 Hz, then the period is 1 ÷ 100 Hz = 0.01 s = 10 ms.
The pulse width is equal to half the period (5 ms in this example). So the frequency stays at 100 Hz for 5 ms 
minimum before changing. If Time Slice is less than half the period, see note b.

1 Return string. If the command succeeds, it returns a string equal to an ASCII value of 01 (3031 hex). If the 
command fails, it returns 00 (3030 hex). No change occurs if it fails. Strings are terminated with an 
End-Of-Message (EOM) character. 
The default EOM character is a Carriage Return, 0x0D. To change it, write to memory map address 
0xF03A8200 for Module 0 Channel 0, 0xF03A8210 for Module 0 Channel 1, 0xF03A8220 for Module 1 Chan-
nel 0, etc. Only the most significant byte is used, bits 24 through 31. Also change this byte with the Set 
End-Of-Message Terminator in PAC Control.
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Example 1

This example ramps from 1 kHz to 25 kHz, 50% duty cycle, in 100 Hz steps every 10 milliseconds. 
Direction pin is asserted. Result is placed in sReturn1. 

Example 2

This example ramps from 1 kHz to 25 kHz, 50% duty cycle, in 100 Hz steps every 10 milliseconds. 
Direction pin is deasserted. The result is placed in sReturn1. 

Example 3

NOTE: If you use “current” as the Start Frequency parameter, the module ramps to the stop frequency from 
its current frequency. 

This example ramps from the chanel’s current frequency to 25 kHz, 50% duty cycle, in 1 Hz steps 
every 1 ms. Direction pin is asserted. The result is placed in sReturn1. 

Configuring Serial Events and Reactions
Data transmitted through a serial module can be used in any of the ways supported by the 
processor’s multiple methods of communication. If you are using PAC Control, use logic in the PAC 
Control strategy to read and write serial data. See the PAC Control User’s Guide (form 1700) for more 
information.

If you are not using PAC Control, you can use PAC Manager to trigger reactions in response to a 
specific string received through a serial module. The string transmitted through the module is the 
event; the reaction in response to that event may include sending an SNMP trap, sending an email 
message, or turning bits on or off in the processor’s Scratch Pad. To configure events and reactions, 
see the chapter “Setting Up Events and Reactions” in the PAC Manager User’s Guide, form 1704.

nStatus = TransmitReceiveString(">SetPulseSequence(1000, 25000, 100, 10)", comScmStPort1, sReturn);

nStatus = TransmitReceiveString(">SetPulseSequence(-1000, -25000, 100, 10)", comScmStPort1, sReturn);

nStatus = TransmitReceiveString(">SetPulseSequence(current, 25000, 1, 1)", comScmStPort1, sReturn);

1 Return string. If the command succeeds, it returns a string equal to an ASCII value of 01 (3031 hex). If the 
command fails, it returns 00 (3030 hex). No change occurs if it fails. Strings are terminated with an 
End-Of-Message (EOM) character. 
The default EOM character is a Carriage Return, 0x0D. To change it, write to memory map address 
0xF03A8200 for Module 0 Channel 0, 0xF03A8210 for Module 0 Channel 1, 0xF03A8220 for Module 1 Chan-
nel 0, etc. Only the most significant byte is used, bits 24 through 31. Also change this byte with the Set 
End-Of-Message Terminator in PAC Control.

http://www.opto22.com/documents/1700_PAC_Control_Users_Guide.pdf
http://www.opto22.com/documents/1704_PAC_Manager_Users_Guide.pdf
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Chapter 4

Additional Tasks

In this chapter:
Loading New Firmware........................................................................................................................... page 33
Removing a Serial Module .................................................................................................................... page 34
Building a Three-Wire Cable for SNAP-SCM-232......................................................................... page 34
Using the SNAP-SCM-232 or SNAP-SCM-485-422 as a Windows COM Port .................. page 34

Loading New Firmware
All SNAP Ethernet-based processors and SNAP serial communication modules contain firmware. 
Each device is shipped from the factory with the latest firmware installed. 

If you need to load new firmware, see form 1704, the PAC Manager User’s Guide, 
for instructions. 

http://www.opto22.com/documents/1704_PAC_Manager_Users_Guide.pdf
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Removing a Serial Module
To remove a serial module, use the 
SNAP module tool that came with the 
module.
1. Turn off power to the rack. 

WARNING: Make sure power is off 
before continuing, or you will 
severely damage the module.

2. Holding the SNAP module tool as 
shown in the illustration at right, 
insert it into the notch at the base 
of the module.

NOTE: If you are facing the rack with 
the processor on the left side, the 
notch is on the back of the module.

3. Squeeze the module tool against 
the module to open the release 
latch, and pull straight up on the 
module to remove it.

Building a Three-Wire Cable for SNAP-SCM-232
Two short, unshielded twisted-pair cables and two RJ45 
to DB-9 (male) adapters are included with the 
SNAP-SCM-232 for easy connection to all types of 
RS-232 devices. If you need to build a three-wire cable to 
run from the PC to a serial module, use the table at right 
as a guide.

See the diagram on page 53 for pin locations.

Using the SNAP-SCM-232 or SNAP-SCM-485-422 as a Windows 
COM Port

For data collection from remote serial devices, where it is impossible or impractical to run serial 
cables, you can use a third-party software driver to redirect virtual Windows COM ports through the 
SNAP-SCM-232 or SNAP-SCM-485-422 module. In this way you can connect an existing Windows 
application that understands only serial communication to a remote SNAP Ethernet-based I/O unit 
attached to serial devices such as barcode readers, intelligent transducers, point-of-sale (POS) 
equipment, serial display devices, scanners, and weather monitoring equipment. 

RJ-45 pin number 
(on serial module)

Female DB-9 pin 
number (on PC)

2 (RX) 3 (TX)

3 (TX) 2 (RX)

5 (GND) 5 (GND)
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The COM port redirect expands the range of your serial application because it eliminates the 
necessity of a serial link between the PC and the serial device. The normal direct connection 
from the PC application to a serial device is shown in the following diagram: 

With redirection, the direct serial connection is not necessary. Serial devices can talk through 
a SNAP serial communication module to the PC application over a local area network or over the 
Internet using TCP/IP, as shown in the diagram below:

The third-party software driver you can use for redirection is a product of Tactical Software, 
LLC and is available from their website at www.tacticalsoftware.com. 

CAUTION: The serial port redirector captures Windows COM port data and routes it through a TCP/IP 
socket to the SNAP serial module. The overhead associated with redirection and network transport time 
may cause serial data to be intermittently transmitted. Data protocols relying on character timing 
transmission intervals are not recommended for redirection applications. 

Also note that serial port handshaking signals, such as RTS and CTS, are not redirected. Some binary data 
protocols may not correctly function; check with the manufacturer.

Requirements
• Opto 22 SNAP Ethernet-based processor 

NOTE: A wireless SNAP Ethernet brain can be used, but you may find that bandwidth and response 
times are not sufficient for your application.
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• Opto 22 SNAP-SCM-232 or SNAP-SCM-485-422 serial communication module(s), 
on a SNAP rack attached to the processor

• Tactical Software’s Serial/IP™ COM port redirector (from www.tacticalsoftware.com)

• Opto 22 PAC Manager (included on the CD that came with the processor, or available from our 
website at www.opto22.com. 

Configuring SNAP Serial Modules
Following directions in “Changing SNAP-SCM-232 and SNAP-SCM-485-422 Communication 
Parameters” on page 15, use PAC Manager to change serial module configuration as follows:

• Set Baud, Parity, Data Bits, and Stop Bits as required by the serial device you are communicating 
with. 

• Set the EOM Char List to zeroes to allow data to pass through.

• Set Power-Up Test Message to NO, so that unwanted characters will not be sent to the 
Windows COM port application.

Installing Software
Read and follow Tactical Software’s Serial/IP documentation to install the Windows serial port 
redirector.

Configuring Redirected COM Ports
When you install the driver, the Select Ports dialog box appears:

1. Check the box for each COM port you wish to redirect. Then click OK.
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The COM ports you checked appear in the next dialog box:

2. For each COM port, do the following:
a. Click the COM port to highlight it.
b. In the IP Address of Server field, enter the IP address of the SNAP Ethernet-based I/O unit 

this COM port will communicate with.
c. In the Port Number field, enter the port number on the serial communication module 

where the device is connected (see the list of port numbers on page 13).
d. In the Connection Protocol area, click Raw TCP Connection. 
e. Under COM Port Options, click Restore Failed Connections to make sure that the serial 

redirector will try to restore communication with the I/O unit if the I/O unit is reset or loses 
power. The DTR and DSR boxes can remain checked.
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When you have finished, the dialog box will look something like this:

3. Click the Configuration Wizard button.

Configuration Wizard button

Start button
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4. In the Configuration Wizard dialog box, press the Start button in the lower-left corner to test 
the connection.

Messages similar to the following appear in the Status and Log areas of the wizard:

The driver is ready to use. You can close the window, as the driver runs in the background.

Consult the Serial/IP user’s guide for additional information and troubleshooting.
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Appendix A

Testing a SNAP-SCM-232 
Ethernet Connection

If you are having trouble establishing an Ethernet connection or sending and receiving data to a 
SNAP-SCM-232, you may want to test the module without using an application such as PAC Control. 
The following steps use the Microsoft Windows® applications Telnet and HyperTerminal to talk to 
each other through the serial module.
1. Make sure you have not changed the serial module’s default of sending a powerup test 

message. (See page 15.) Leave power to the SNAP Ethernet-based I/O unit turned off, 
so that HyperTerminal can capture the test message.

2. Plug the module’s serial port into a PC serial port using a three-wire cable.

If you need to build the cable, see page 34.

3. Start HyperTerminal (Start > Programs > Accessories > HyperTerminal) and open the serial port 
using the module’s default settings: 9600 baud, no parity, 8 data bits, 1 stop bit, and no 
handshaking.

4. Turn on the I/O unit. Watch the TX LEDs on the serial module.

The TX LEDs blink in the following pattern: three quick blinks to indicate power; then two blinks 
to indicate a connection to the processor; and finally a single blink to indicate transmittal of a 
test message like the following:
Opto 22 SNAP-SCM232, Ver 00.01.01.01, Module 7, Port 0, 9600,N,8,1 

NOTE: The final single blink that indicates test message transmittal may be turned off. You can enable 
or disable it using the Configure Serial Module dialog box in PAC Manager.

5. From the Start menu, open a command prompt. Establish a Telnet connection to the port, 
using the IP address of the I/O unit and the IP port number of the serial port on the module. 

For example, type Telnet 10.192.55.62 22500 to establish a connection to serial port 
22500 (port 0 of the serial module in position zero) on an I/O unit with the IP address 
10.192.55.62. See the table on page 13 for other port numbers. 

6. Type anything in HyperTerminal.

The characters should be transmitted through the serial port and appear on Telnet.

7. Type characters in Telnet.

They are transmitted through the serial port and should appear on HyperTerminal.

If you continue to have trouble communicating with the module, contact Opto 22 Product Support. 
See page 4 for contact information.
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Appendix B

Using SNAP Serial Modules 
with Legacy Hardware

In this appendix:
Overview .............................................................page 43
Checking the Firmware Version ................page 44

Overview
Some SNAP serial communication modules can also be used with the following legacy I/O 
processors on M-series or B-series mounting racks. Make certain you have the correct rack for the 
processor you are using (see the processor’s user guide for information).

Minimum firmware for current and legacy processors is shown in the following table. Firmware 
must be the version shown or newer in order to work with the module described.

SNAP Ethernet: SNAP-B3000-ENET
SNAP-ENET-RTC

SNAP Simple: SNAP-ENET-S64

SNAP Ultimate: SNAP-UP1-ADS
SNAP-UP1-M64

Module Minimum Processor Firmware

SNAP PAC R
SNAP PAC EB

SNAP Ethernet SNAP Simple SNAP Ultimate 

SNAP-SCM-232 
(No flow control) All

R1.3h (1.3.2.7) with serial mod-
ule firmware 1.1.2.5 or older

R3.0a (3.0.2.0) with serial mod-
ule firmware 1.1.2.B or newer

All R1.0a (1.0.2.0)

SNAP-SCM-232 
(With flow control) All R5.0a All R5.0a

SNAP-SCM-485 or 
SNAP-SCM-485-422

(2-wire RS-485) 
All

R1.3h (1.3.2.7) with serial mod-
ule firmware 1.1.2.5 or older

R3.0a (3.0.2.0) with serial mod-
ule firmware 1.1.2.B or newer

All R1.0a (1.0.2.0)
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Checking the Firmware Version
If you need to check the processor’s firmware version, follow these steps. You’ll need to have PAC 
Manager installed on your computer. PAC Manager is located on the CD that came with the 
processor and is also available for free download from our website at www.opto22.com.
1. On a PC on the same Ethernet network as the processor, choose Start > Programs > Opto 22 > 

PAC Project > PAC Manager.

2. In the PAC Manager main window, click the Inspect icon  or choose Tools > Inspect.

3. In the Device Name field, type in the IP address of the I/O unit. Click the Status Read button at 
the top left side of the Inspect window.

SNAP-SCM-485-422
(4-wire RS-485/422) All R5.0a All R5.0a

SNAP-SCM-W2 All R3.0k (3.0.2.10) All R1.0 (1.0.2.B)

SNAP-SCM-PROFI All R6.1c R6.1c R6.1c

SNAP-SCM-CAN2B 9.2a Not supported

SNAP-SCM-ST2 9.1a Not supported

Module Minimum Processor Firmware

SNAP PAC R
SNAP PAC EB

SNAP Ethernet SNAP Simple SNAP Ultimate 

Inspect icon
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The status information from the I/O unit is displayed in the window:

4. Find the value for Firmware revision (in the example above, R5.1g) and compare it to the 
required firmware version number in the table on page 43. If the version number is older than 
the minimum processor firmware shown, follow instructions in the processor’s user guide to 
download new firmware.
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Appendix C

Specifications, LEDs, and 
Module Switches

In this appendix:
Specifications ............................................................................page 48
LED Indicators ...........................................................................page 53
Module Switches .....................................................................page 55
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Specifications

SNAP-SCM-232 and SNAP-SCM-485-422 Specifications

Baud rates 300–115,200*

Channel-to-channel isolation 750 VRMS

Logic supply voltage 5.0 VDC

Logic supply current 250 mA DC

Number of ports per module 2 (1 if SNAP-SCM-485-422 in 4-wire mode)

Max. number of modules per 
rack** 8

Maximum cable length, 
point-to-point (SNAP-SCM-232) 50 feet

Maximum cable length, multidrop 
(SNAP-SCM-485-422) 1,000 feet at 115,200 Kbd

Processor compatibility

SNAP PAC R-series controllers and SNAP 
PAC EB brains, both standard wired and 
Wired+Wireless models.
Also SNAP-B3000-ENET, 
SNAP-ENET-RTC, SNAP-ENET-S64, 
SNAP-UP1-ADS, and SNAP-UP1-M64.

Operating temperature 0 to 70 °C

Storage temperature -30 to 85 °C

Torque, hold-down screws 4 in-lb (0.45 N-m)

Torque, connector screws 5.26 in-lb (0.6 N-m)

Agency Approvals CE, FM, RoHS, DFARS

Warranty 30 months

* Module performance is limited by the number of serial modules on the SNAP 
rack. Each rack backplane provides approximately 2.5 Mbps of bandwidth. 
** Maximum number of modules per rack assumes an Opto 22 SNAP power sup-
ply and SNAP rack.
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SNAP-SCM-PROFI Specifications

Baud rates 9600 to 1.5 MBaud* 

Channel-to-channel isolation 750 Vrms

Logic supply voltage 5.0 VDC

Logic supply current 250 mA

Number of ports per module 1

Maximum number of modules per rack* 8

Processor compatibility

SNAP PAC R-series controllers and SNAP PAC EB brains, both 
standard wired and Wired+Wireless models.
Also SNAP-B3000-ENET, SNAP-ENET-RTC, SNAP-ENET-S64, 
SNAP-UP1-ADS, and SNAP-UP1-M64.

Processor firmware Firmware 6.1c or newer required

Operating temperature 
Storage temperature

0 to 70 °C
-30 to 85 °C

Torque, hold-down screws 4 in-lb (0.45 N-m)

Torque, connector screws 5.26 in-lb (0.6 N-m)

Agency Approvals CE, RoHS, DFARS

Warranty 30 months

* Module performance is limited by the number of serial modules on the SNAP rack. Each rack backplane 
provides approximately 2.5 Mbps of bandwidth.
** With Opto 22 SNAP power supply and SNAP rack
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SNAP-SCM-W2 Specifications

SNAP-SCM-W2 Maximum Cable Lengths for Conductor Size

Channel-to-channel isolation 250 Vrms

Logic supply voltage 5.0 VDC (± 0.15)

Logic supply current 250 mA 

Number of ports per module 2

Maximum number of mod-
ules per rack* 8

Maximum cable length See table below

Processor compatibility

SNAP PAC R-series controllers and SNAP PAC EB brains, both 
standard wired and Wired+Wireless models.
Also SNAP-B3000-ENET, SNAP-ENET-RTC, SNAP-ENET-S64, 
SNAP-UP1-ADS, and SNAP-UP1-M64.

Operating Temperature 
Storage Temperature

0 to 70 °C operating 
-30 to 85 °C storage

Torque, hold-down screws 4 in-lb (0.45 N-m)

Torque, connector screws 5.26 in-lb (0.6 N-m)

Agency Approvals CE, RoHS, DFARS

Warranty 30 months

* With Opto 22 SNAP power supply and SNAP rack

Cable Length Conductor Size

Up to 200 ft. (60 m) 22 GA stranded or larger

Up to 300 ft. (90 m) 20 GA stranded or larger

Up to 500 ft. (150 m) 18 GA stranded or larger
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SNAP-SCM-CAN2B Specifications

SNAP-SCM-ST2 Specifications

Baud rates 10–1000 Kbps*

Logic supply voltage 5.0 VDC

Logic supply current 250 mA DC

Number of ports per module 1

Max. number of modules per rack** 8

Processor compatibility

SNAP PAC R-series controllers and SNAP 
PAC EB brains, both standard wired and 
Wired+Wireless models, with firmware 9.2a 
or newer.

Operating temperature 0 to 70 °C

Storage temperature -30 to 85 °C

Torque, hold-down screws 4 in-lb (0.45 N-m)

Torque, connector screws 5.26 in-lb (0.6 N-m)

Agency Approvals CE, FM, RoHS, DFARS

Warranty 30 months from date of manufacture

* Module performance is limited by the number of serial modules on the SNAP rack. 
Each rack backplane provides approximately 2.5 Mbps of bandwidth. 
** Maximum number of modules per rack assumes an Opto 22 SNAP power supply 
and SNAP rack.

Frequency Range 0.13–50,000 Hz

Pulse Width Range1 3.84 Sec to 10 µSec

Pulse Width Accuracy2 0–2 Hz, 2–30 Hz, 30–50,000 Hzv
(see graphs on the next page)

Output Format CMOS/TTL Compatible

Logic Supply Voltage 5.0 VDC

Logic Supply Current 200 mA

Compatible I/O Processors SNAP PAC R-series controllers and EB-series brains with R9.1a or 
newer firmware

Duty Cycle Fixed at 50%

Number of Ports per Module 2

Operating Temperature Range 0–60 °C

Storage Temperature Range -30–85 °C



SPECIFICATIONS

SNAP Serial Communication Module User’s Guide52

Warranty 30 months from date of manufacture

1Pulse Width is equal to one-half the period.
2To find the frequency error in Hz:
Frequency Error (+/-) = Desired Frequency - (1 ÷ (Pulse Width Resolution + (1 ÷ Desired Frequency))).
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LED Indicators

SNAP-SCM-232 and 
SNAP-SCM-485 LEDs
LEDs are the same for SNAP-SCM-232 and 
SNAP-SCM-485-422 modules. Transmit and receive 
LEDs are provided for each port as shown in the 
diagram at right. 

If you are using the SNAP-SCM-485-422 in 4-wire 
mode, only LEDs 1 and 3 are used.

Since SNAP-SCM-W2 modules receive but do not 
transmit, LEDs 1 and 2 are not used. LEDs 3 and 4 
function as shown in the diagram. 

SNAP-SCM-PROFI LEDs 

SNAP-SCM-CAN2B LEDs

SNAP-SCM-CAN2B Error Codes. The #4 LED indicates an error on the CAN bus. See the OptoMMP 
Protocol Guide, form 1465, for the memory map addresses required to access the error codes. 
Reading the error code from the memory map clears the error. Possible error codes include the 
following:

LED Indication

1 TEST

2 TRANSMIT

3 POWER

4 RECEIVE

LED Type Indicates

1 CAN Bus Activity Communication activity with the CAN controller. This LED illuminates when the CAN 
controller is configured or when a CAN packet is accepted by the module.

2 STATUS
2 Blinks: SNAP-SCM-CAN2B firmware has started. 
5 Blinks: firmware error. 
8 Blinks: CAN Controller error. 

3 POWER Power is applied to the module.

4 ERROR Error on the CAN bus. See below.

Error Codes Description

0 Error—Active State. The SNAP-SCM-CAN2B has received less than 96 errors.

LED Indicators, SNAP-SCM-232 and 
SNAP-SCM-485-422 (top view)
(SNAP-SCM-232 shown as example)
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SNAP-SCM-ST2 LEDs

-1 Error—Active State. The SNAP-SCM-CAN2B has received 96 or more errors but less than 
128 errors.

-2 

Receiver Overflow. A CAN packet was dropped. This happens when the 
SNAP-SCM-CAN2B can't keep up with the traffic on the CAN bus. This means the internal 
buffer on the CAN2B module is full. This could happen if the strategy isn't reading the data 
fast enough or too many serial modules are on the rack.  To resolve it you can configure the 
Data Masks and Filters to receive less CAN packets, reduce the number of serial modules 
on the rack, or increase the frequency the strategy reads the module.

-3 Error—Passive State. The SNAP-SCM-CAN2B has received 128 or more errors but less 
than 255 errors.

LED Description

1 Blinks when outputting pulses on channel 1

2 Positive/Negative direction indicator on channel 1

3 Blinks when outputting pulses on channel 2

4 Positive/Negative direction indicator on channel 2

Error Codes Description
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Module Switches

Module Switches—SNAP-SCM-PROFI

The SNAP-SCM-PROFI module is designed to work with either 
a standard PROFIBUS DP® cable or a custom-built PROFIBUS DP 
cable. The positions of the communication switches when used 
with a standard PROFIBUS cable are shown in the diagram at left.

If you are using a cable other than a standard PROFIBUS cable, 
set the switches as appropriate for the layout of your system.

Module Switches—SNAP-SCM-W2

The switches on the top of the SNAP-SCM-W2 are set at the 
factory and should not be changed from their factory defaults. 
Factory default positions are shown in the diagram at left.

OFF ON

OFF ON
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